Ad Menu

Gmail Backup

Gmail Backup:
Gmail Backup è un'applicazione con interfaccia grafica che permette a coloro che hanno un account gmail, di fare il backup e/o il ripristino della posta.
Il programma utilizza il protocollo IMAP, ed è quindi in grado di ripristinare anche le etichette.
Gmail Backup permette di preservare lo stato della posta letta o non letta, di fare il backup incrementale, di impostare un periodo prestabilito, di includere o escludere specifiche etichette.
Inoltre si possono applicare filtri, e creare diversi profili, adatta a coloro che hanno tantissima posta.



Installazione:
Aprire un terminale e digitare:

sudo apt-get install python-pyside.qtgui python-pyside.qtcore

Scaricare il programma da: Qui.
Estrarre l'archivio, entrare nella cartella risultante e fare doppio-click sul file: "gui.py".
Il primo backup deve essere eseguito senza l'opzione incrementale.
Gmail Backup può essere utilizzato anche da riga di comando: entrare nella cartella di destinazione e digitare: «./backup_gmail.py --help», per visualizzare tutte le opzioni.
Questo è tutto;)

Share/Bookmark
Stampa il Post - Print this Post

Comments :

6 commenti to “ Gmail Backup ”
alex ha detto...
on  

non riesco ad installare python-pyside.qtgui

Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze
Lettura informazioni sullo stato... Fatto
E: Impossibile trovare il pacchetto python-pyside.qtgui

silvio1964 ha detto...
on  

Ci deve'essere: è nel repo ufficiale,ciao

alex ha detto...
on  

io utilizzo ubuntu lucid 10.04
e non trovo questi paccheti
infatti
http://packages.ubuntu.com/search?keywords=python-pyside.qtgui
e
http://packages.ubuntu.com/search?keywords=python-pyside.qtcore

lucid non risulta
come posso fare per installre
questi pacchetti mancanti

silvio1964 ha detto...
on  

Solo per Lucid:

sudo add-apt-repository ppa:pyside/ppa

sudo apt-get update

Installare come descritto, ma se non funziona digita:

sudo apt-get install pyside

Fammi sapere, che ti cerca l'alternativa,Ciao:)

alex ha detto...
on  

ok perfetto ora le lirerie
sono riuscito ad installarle
sudo apt-get install python-pyside.qtgui python-pyside.qtcor

ma quando avvio "gui.py" con doppio clic
o dal terminale
ti riporto il messaggio
e Gmail Backup
non si avvia.....


"Traceback (most recent call last):
File "./gui.py", line 367, in
main = MainWindow()
File "./gui.py", line 71, in __init__
self.label_filter_text.setPlaceholderText("Keep empty to fetch all labels")
AttributeError: 'PySide.QtGui.QLineEdit' object has no attribute 'setPlaceholderText'"

silvio1964 ha detto...
on  

Il problema è che la versione di python cambia tra lucid, maverick, o natty.
Il repo che ti proposto ha installato pyside 1.0.3, e ti ci vuole invece la versione 1.0.1 oppure 1.0.2.
La prima non stata pacchettizzata con successo, mentre la seconda è disponibile.
Procedi quindi con:

sudo ppa-purge ppa: pyside/ppa

seleziona la disinstallaazione durante la procedura. controlla dopo anche in synaptic l'avvenuta rimozione dei pacchetti.
Aggiungi poi il repo presumibilmente giusto con:

sudo add-apt-repository ppa:odyx/lucid-pyside-1.0.2

sudo apt-get update

sudo apt-get install python-pyside.qtgui python-pyside.qtcore

Se non funziona neanche questo devo cercare la versione 1.0.1 fammi sapere, ciao;)

Related Posts with Thumbnails